logo
down
shadow

Failed to execute goal com.google.appengine:appengine-maven-plugin:1.9.67:devserver


Failed to execute goal com.google.appengine:appengine-maven-plugin:1.9.67:devserver

By : nithun
Date : November 22 2020, 07:01 PM
I wish did fix the issue. Hey i have a problem starting my maven project on devserver and update calls. I buils my maven project to run with google cloud engine, but im getting this issue and cant start my server. This is my pom.xml : , Adding the
code :
    <project>YOUR PROJECT ID</project>
    <groupId>com.google.cloud.tools</groupId>
    <artifactId>appengine-maven-plugin</artifactId>
    <groupId>com.google.appengine</groupId>
    <artifactId>appengine-maven-plugin</artifactId>
    <pluginManagement>
      <plugins>
          <plugin>
              <groupId>com.google.appengine</groupId>
              <artifactId>appengine-maven-plugin</artifactId>
              <version>${appengine.target.version}</version>
              <configuration>
                  <project>YOUR PROJECT ID</project> <!-- WHAT DO WE NEED THIS FOR-->
                  <jvmFlags>
                      <jvmFlag>-Ddatastore.backing_store=${project.basedir}/local_db.bin</jvmFlag>
                  </jvmFlags>
                  <fullScanSeconds>-1</fullScanSeconds>
              </configuration>
          </plugin>
      </plugins>
  </pluginManagement>


Share : facebook icon twitter icon
Maven GAE Failed to execute goal com.google.appengine:appengine-maven-plugin:1.9.12:devserver [...] NoSuchElementExcepti

Maven GAE Failed to execute goal com.google.appengine:appengine-maven-plugin:1.9.12:devserver [...] NoSuchElementExcepti


By : Tom Hubbard
Date : March 29 2020, 07:55 AM
it fixes the issue According to this page, https://code.google.com/p/appengine-maven-plugin/issues/detail?id=41 , you need to add the plugin not only in the section, but also in the section. So you would need to extend your pom as follows:
code :
<build>
    <outputDirectory>${project.build.directory}/${project.build.finalName}/WEB-INF/classes</outputDirectory>
    <pluginManagement>
        <!-- other plugins here -->
        <plugin>
            <groupId>com.google.appengine</groupId>
            <artifactId>appengine-maven-plugin</artifactId>
            <version>1.9.12</version>
            <configuration>
                <enableJarClasses>false</enableJarClasses>
            </configuration>
        </plugin>
    </pluginManagement>
    <plugins>
        <plugin>
            <groupId>com.google.appengine</groupId>
            <artifactId>appengine-maven-plugin</artifactId>
        </plugin>
    </plugins>
</build>
com.google.appengine:appengine-maven-plugin:1.9.18:update failed. NoSuchElementException ->

com.google.appengine:appengine-maven-plugin:1.9.18:update failed. NoSuchElementException ->


By : user3222304
Date : March 29 2020, 07:55 AM
wish of those help Here is how I fixed this issue -
I manually added appengine-api-1.0-sdk-1.9.18.jar into java build path. I manually added JRE system library(JavaSE-1.7) into the build path. Initially it was JDK. In java build path - order and export tab, manually moved above mentioed jar to the up, so that Eclipse will know which jar to take while compiling the project.
Execution default-cli of goal com.google.appengine:appengine-maven-plugin:1.9.32:update failed

Execution default-cli of goal com.google.appengine:appengine-maven-plugin:1.9.32:update failed


By : LakshmiNarayanan
Date : March 29 2020, 07:55 AM
Hope that helps In this case you have a multi-module Maven project and you are trying to execute the appengine:update goal on the whole build, which is probably not possible, because the parent/aggregator pom (where the build is failing) would not provide the folders structure the goal is expecting and as such causing errors.
In fact, you don't want to execute appengine:update on the parent, the shared or model module, among others.
code :
mvn clean install
cd mz-web-server <-- move to the concerned module
mvn appengine:update
<project>
    <build>
        <pluginManagement>
            <plugins>
                <plugin>
                    <groupId>com.google.appengine</groupId>
                    <artifactId>appengine-maven-plugin</artifactId>
                    <version>${appengine.version}</version>
                </plugin>

                <plugin>
                    <groupId>com.google.appengine</groupId>
                    <artifactId>gcloud-maven-plugin</artifactId>
                    <version>${gcloud.plugin.version}</version>
                </plugin>
            </plugins>
        </pluginManagement>
    </build>

    <profiles>
        <profile>
            <!-- do you really need it? :) -->
        </profile>
    </profiles>
</project>
<project>

    <build>
        <plugins>
            <plugin>
                <groupId>com.google.appengine</groupId>
                <artifactId>appengine-maven-plugin</artifactId>
                <!-- you don't need to re-define the version here -->
                <!-- version is taken from pluginManagement from the parent -->
                <configuration>
                    <enableJarClasses>false</enableJarClasses>
                    <version>${app.version}</version>
                </configuration>
            </plugin>

            <plugin>
                <groupId>com.google.appengine</groupId>
                <artifactId>gcloud-maven-plugin</artifactId>
                <!-- again, no version here -->
                <configuration>
                    <set_default>true</set_default>
                </configuration>
            </plugin>

        </plugins>
    </build>

</project>
Could not find goal 'run' in plugin com.google.appengine:appengine-maven-plugin

Could not find goal 'run' in plugin com.google.appengine:appengine-maven-plugin


By : 小狼先生
Date : March 29 2020, 07:55 AM
wish helps you The goal run cannot be found because the plugin has no such goal. I believe you are looking for appengine:devserver. See Testing you app with the development server section within Using Apache Maven and the App Engine Plugin.
In reference to your second question as shown in your edit above. The answer, which is cryptic, points to an issue with thrown exceptions. Your overriden method must throw the same exceptions, which is not only IOException but also ServletException.
mvn appengine:devserver [ERROR] Could not find goal 'devserver' in plugin com.google.cloud.tools:appengine-maven-plugin:

mvn appengine:devserver [ERROR] Could not find goal 'devserver' in plugin com.google.cloud.tools:appengine-maven-plugin:


By : chris
Date : March 29 2020, 07:55 AM
it fixes the issue There are two App Engine Maven plugins you can use to launch your SpringBoot app: App Engine SDK-based and Cloud SDK-based.
The App Engine SDK-based plugin should have the following groupId entry in pom.xml:
code :
<groupId>com.google.appengine</groupId> 
<groupId>com.google.cloud.tools</groupId> 
Related Posts Related Posts :
  • How do I disable Hot Code Replace in Eclipse
  • GWT Post build command in Eclipse
  • Does m2eclipse need EGit for git support
  • P2 Touchpoint chmod not working?
  • Eclipse auto-complete of filenames
  • Eclipse, the AVR Plugin, and Arduino
  • m2eclipse and WTP and adding local project source
  • Import package problem in GWT
  • How to host eclipse plugins(cheatsheet)?
  • Maven downloads have .lastUpdated as extension
  • How do you cleanly uninstall the Eclipse MapReduce plugin?
  • eclipse 3.5.1 (Galileo) with ubuntu 9.10 (Karmic) busted! Can not install maven2 plugin! (Or any other plugin)
  • How to search string under cursor in Eclipse
  • With Eclipse, in a PHP project with SVN, how to "tell" Eclipse to find autocompletion choice only in the curre
  • Eclipse Gurus: where can I find information to make a theme for the IDE? (I wish similar to Chrome)
  • How to skip parentheses on Netbeans with enter?
  • Which information (files) of an eclipse-workspace should be tracked by source control
  • Java process problem in Eclipse
  • Eclipse (Springsource Tool Suite 2.3.1) can't resolve dependencies for classes in the same package
  • How do i remove m2eclipse from my eclipse installation?
  • Problem Setting VM Arguments with Eclipse 3.5.2
  • Changing UI color in Eclipse
  • Eclipse: Making Eclipse's "search in project" less unhelpful?
  • How to find Junit tests that are using a given Java method directly or indirectly
  • Environment variables in eclipse.ini file
  • Problems by import of a multiple modules maven 2 project into eclipse workspace
  • How can I write to the setup file from Navigate - Open Setup?
  • Enormous tab and icon padding in Eclipse 4.11 on Ubuntu 19.04
  • Cucumber-Maven Set up with Eclipse, Source option 5 is no longer supported. Use 7 or later
  • How to fix this issue with JSP?
  • How do I get Robotframework (in Eclipse) to respond to terminal prompt
  • target/ vs /target/ in .gitignore
  • Unable to create hibernate.cfg.xml through eclipse wizard?
  • ARM Eclipse debugging code in the RAM. Is it possible to see the source code`
  • Why does restoring Eclipse / Content Assist defaults not persist when Eclipse is closed and later re-opened?
  • Eclipse how to disable validation for txt file (lsp4e)
  • Why the main method cant be loaded
  • Error occurred during initialization of boot layer java.lang.module.FindException executing Selenium tests using TestNG
  • Custom XML formatter for Eclipse
  • Kotlin not working with Eclipse Workspace Resolution
  • Eclipse 4.12 - java.lang.ClassNotFoundException: com.sun.xml.internal.bind.v2.ContextFactory
  • Execute XSJS program in SAP HANA Neo using Eclipse
  • How do I connect from Eclipse Neon to SAP Web IDE Full-Stack?
  • GitHub OAuth is not configured. Configure OAuth in the che.properties file
  • Unable to resolve maven-resources-plugin:2.19.1 dependencies in Eclipse | Maven version - 3.6.1
  • eclipse run/debug launch configs in ws/.../.launch do not show up in config dialog
  • ClassNotFoundException when launching junit tests in Eclipse 2019-12 on Windows when using Java 9+
  • Dictionary in UIMA RUTA in Eclipse
  • shadow
    Privacy Policy - Terms - Contact Us © 35dp-dentalpractice.co.uk